CVE-2025-46337

CRITICAL

ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. Prior to version 5.22.9, improper escaping of a query parameter may allow an attacker...

Affects 0 products across 2 vendors.

CVSS 3.110.0
EPSS0.7%
Percentile54th
PatchUnknown
CVSS Vector — Plain English Remotely exploitable over the network, low complexity, no authentication required, no user interaction needed, can impact systems beyond the vulnerable component, full confidentiality impact, full integrity impact.
CWE Weakness Definitions
CWE-89: SQL Injection

Attacker inserts SQL commands into application queries through user-controlled input, allowing unauthorized database access.

Related Attack Patterns (CAPEC)
CAPEC-7 Blind SQL Injection
via CWE-89
CAPEC-108 Command Line Execution through SQL Injection
via CWE-89
CAPEC-109 Object Relational Mapping Injection
via CWE-89
CAPEC-110 SQL Injection through SOAP Parameter Tampering
via CWE-89
CAPEC-470 Expanding Control over the Operating System from the Database
via CWE-89
Show all 6
via CWE-89

Mapping is CWE-to-CAPEC per MITRE CAPEC 3.9.

◆ AI Analysis — automated analysis, not human-reviewed

CVE-2025-46337 affects ADOdb versions prior to 5.22.9, allowing SQL injection via improper escaping of query parameters when using pg_insert_id() with user-supplied data on PostgreSQL databases.

BSID: BS-2025-GLOBAL-261237-C • Model: /workspace/models/qwen2.5-coder-32b-instruct-bf16 • Confidence: HIGH

Is this CVE in your environment?

BreachSpider monitors your ICS/OT environment for vulnerabilities like this one. No agents or network access required. Free to start.

Check My Environment →
Frequently Asked Questions
What is CVE-2025-46337?
CVE-2025-46337 affects ADOdb versions prior to 5.22.9, allowing SQL injection via improper escaping of query parameters when using pg_insert_id() with user-supplied data on PostgreSQL databases.
What is the CVSS score for CVE-2025-46337?
CVE-2025-46337 has CVSS 10.0 (Critical). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L. EPSS: 0.7%.
Is CVE-2025-46337 actively exploited?
No confirmed active exploitation of CVE-2025-46337 as of 2026-09-25.
How do I remediate CVE-2025-46337?
Priority: IMMEDIATE.
What systems are affected by CVE-2025-46337?
CVE-2025-46337 affects Class; Postgresql.
Vulnerability Details
CVE IDCVE-2025-46337
BSIDBS-2025-GLOBAL-261237-C BreachSpider Global ID
CVSS VectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L
Published2025-05-01
Last Modified2026-06-17
ICS Relevance0%
Weakness (CWE)
SourceNVD
Official Description

ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. Prior to version 5.22.9, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a PostgreSQL database and calls pg_insert_id() with user-supplied data. This issue has been patched in version 5.22.9.

Source: NIST NVD / MITRE CVE Database

Attack Vector Analysis — CITED Relevance

An attacker can exploit this vulnerability by providing specially crafted input to the pg_insert_id() function, which can lead to the execution of arbitrary SQL statements on the database.

Exploitation Likelihood: HIGH

Affected Products
VendorProductAffected Versions
Class — —
Postgresql — —
Remediation

No official vendor advisory link on record. See the CVE record →

Threat Intelligence
● Threat Intelligence Validated: October 2026 | Threat Age: 532 Days
CISA known-exploitedNot in KEV catalog
Public ExploitNot confirmed
PoC CodeNot confirmed
AI Enrichment Record — provenance & audit hash
Model/workspace/models/qwen2.5-coder-32b-instruct-bf16
ConfidenceHIGH
Enriched At2026-05-24
SHA-512 Audit Hashdfe6fa6c40c0cb2c4c1aea712571d798eda157f6b1ad500724068b0954eff0a0dfc2cd4a7b03c2c80959474e7e9b27148efe01a791cf88a9f8154922b043eabf
Related CVEs affecting Class
CVE-2024-56799 10.0 Simofa is a tool to help automate static website building and deployment. Pri... CVE-2025-54119 10.0 ADOdb is a PHP database class library that provides abstractions for performi... CVE-2025-70974 10.0 Fastjson before 1.2.48 mishandles autoType because, when an @type key is in a... CVE-2026-31235 9.8 The imgaug library thru 0.4.0 contains an insecure deserialization vulnerabil... CVE-2026-31072 9.8 The JSONSerializer and CBORSerializer in APScheduler (all versions including ...
View all Class CVEs →

Critical Severity - Know Your Exposure

A CVSS 10.0 vulnerability in your ICS environment cannot wait. BreachSpider maps critical CVEs to your specific assets and tells you what to fix first.

Create a free account →