CVE-2026-22774
Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. From 5.3.0 to 5.6.1, certain inputs can cause devalue.parse to consume e...
Affects 1 product across 1 vendor.
CVE-2026-22774 affects Svelte devalue versions 5.3.0 to 5.6.1, where certain inputs can cause excessive CPU time and/or memory consumption, leading to potential denial of service in systems parsing untrusted data.
BSID: BS-2026-GLOBAL-069284-H • Model: /workspace/models/qwen2.5-coder-32b-instruct-bf16 • Confidence: MEDIUM
Is this CVE in your environment?
BreachSpider monitors your ICS/OT environment for vulnerabilities like this one. No agents or network access required. Free to start.
Check My Environment →What is CVE-2026-22774?
What is the CVSS score for CVE-2026-22774?
Is CVE-2026-22774 actively exploited?
How do I remediate CVE-2026-22774?
What systems are affected by CVE-2026-22774?
| CVE ID | CVE-2026-22774 |
|---|---|
| BSID | BS-2026-GLOBAL-069284-H BreachSpider Global ID |
| CVSS Vector | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H |
| Published | 2026-01-15 |
| Last Modified | 2026-07-15 |
| ICS Relevance | 0% |
| Weakness (CWE) | |
| Source | NVD |
Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. From 5.3.0 to 5.6.1, certain inputs can cause devalue.parse to consume excessive CPU time and/or memory, potentially leading to denial of service in systems that parse input from untrusted sources. This affects applications using devalue.parse on externally-supplied data. The root cause is the typed array hydration expecting an ArrayBuffer as input, but not checking the assumption before creating the typed array. This vulnerability is fixed in 5.6.2.
Source: NIST NVD / MITRE CVE Database
Attackers can exploit this vulnerability by providing specially crafted input to the devalue.parse function, causing the system to consume excessive resources and potentially leading to a denial of service condition.
Exploitation Likelihood: MEDIUM
| Vendor | Product | Affected Versions |
|---|---|---|
| Svelte | Devalue | ≥ 5.3.0, < 5.6.2 |
No official vendor advisory link on record. See the CVE record →
| CISA known-exploited | Not in KEV catalog |
|---|---|
| Public Exploit | Not confirmed |
| PoC Code | Not confirmed |
AI Enrichment Record — provenance & audit hash
| Model | /workspace/models/qwen2.5-coder-32b-instruct-bf16 |
|---|---|
| Confidence | MEDIUM |
| Enriched At | 2026-05-24 |
| SHA-512 Audit Hash | 2c287410fc3f2b37e0321458985df851b52c845c0541e4ee4b1acda0769b66a385e518bb42c8f0e53994dd11ad8e95f960020cd75ced889f6f81ef1600b8c0b3 |
ICS/OT Vulnerability Intelligence for Your Environment
BreachSpider tracks 384,000+ CVEs and matches them to your ICS/OT assets by exact version, with AI analysis, NERC CIP mapping, and vendor PSIRT contacts.
Create a free account →