CVE-2026-44167

HIGH

phpseclib is a PHP secure communications library. Prior to 1.0.29, 2.0.54, and 3.0.52, anyone loading untrusted ASN1 files (eg. X509 certificates, RSA PKCS8 private or public keys, etc). This is a ...

Affects 0 products across 1 vendor.

CVSS 3.17.5
EPSS0.3%
Percentile26th
PatchUnknown
CVSS Vector — Plain English Remotely exploitable over the network, low complexity, no authentication required, no user interaction needed, impact contained to the vulnerable component, no confidentiality impact, no integrity impact, full availability impact.
CWE Weakness Definitions
CWE-400: Uncontrolled Resource Consumption (DoS)

Software does not properly limit resource usage, allowing an attacker to exhaust CPU, memory, disk, or bandwidth.

Related Attack Patterns (CAPEC)
CAPEC-147 XML Ping of the Death
via CWE-400
CAPEC-492 Regular Expression Exponential Blowup
via CWE-400
CAPEC-227 Sustained Client Engagement
via CWE-400

Mapping is CWE-to-CAPEC per MITRE CAPEC 3.9.

◆ AI Analysis — automated analysis, not human-reviewed

A vulnerability in phpseclib prior to versions 1.0.29, 2.0.54, and 3.0.52 allows attackers to bypass a previous security fix (CVE-2024-27355) by loading untrusted ASN1 files, potentially leading to unauthorized access or other security issues.

BSID: BS-2026-GLOBAL-153365-H • Model: /workspace/models/qwen2.5-coder-32b-instruct-bf16 • Confidence: HIGH

Is this CVE in your environment?

BreachSpider monitors your ICS/OT environment for vulnerabilities like this one. No agents or network access required. Free to start.

Check My Environment →
Frequently Asked Questions
What is CVE-2026-44167?
A vulnerability in phpseclib prior to versions 1.0.29, 2.0.54, and 3.0.52 allows attackers to bypass a previous security fix (CVE-2024-27355) by loading untrusted ASN1 files, potentially leading to unauthorized access or other security issues.
What is the CVSS score for CVE-2026-44167?
CVE-2026-44167 has CVSS 7.5 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H. EPSS: 0.3%.
Is CVE-2026-44167 actively exploited?
No confirmed active exploitation of CVE-2026-44167 as of 2026-05-30.
How do I remediate CVE-2026-44167?
Priority: HIGH.
What systems are affected by CVE-2026-44167?
CVE-2026-44167 affects Phpseclib.
Vulnerability Details
CVE IDCVE-2026-44167
BSIDBS-2026-GLOBAL-153365-H BreachSpider Global ID
CVSS VectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Published2026-05-12
Last Modified2026-05-13
ICS Relevance15%
Weakness (CWE)
SourceNVD
Official Description

phpseclib is a PHP secure communications library. Prior to 1.0.29, 2.0.54, and 3.0.52, anyone loading untrusted ASN1 files (eg. X509 certificates, RSA PKCS8 private or public keys, etc). This is a bypass of CVE-2024-27355. This vulnerability is fixed in 1.0.29, 2.0.54, and 3.0.52.

Source: NIST NVD / MITRE CVE Database

Attack Vector Analysis — CITED Relevance

The attack vector involves an attacker providing malicious ASN1 files, such as X509 certificates or RSA PKCS8 keys, to a system using an affected version of phpseclib. This can lead to a bypass of security checks and potential exploitation of the system.

Exploitation Likelihood: MEDIUM

Affected Products
VendorProductAffected Versions
Phpseclib — —
Remediation

No official vendor advisory link on record. See the CVE record →

Threat Intelligence
● Threat Intelligence Validated: October 2026 | Threat Age: 156 Days
CISA known-exploitedNot in KEV catalog
Public ExploitNot confirmed
PoC CodeNot confirmed
AI Enrichment Record — provenance & audit hash
Model/workspace/models/qwen2.5-coder-32b-instruct-bf16
ConfidenceHIGH
Enriched At2026-05-24
SHA-512 Audit Hashef11aaeda720d82cccbce730f3d2f13513c97e05bac0bb993aeb672dfce5a241ff4f52ec942da435438650317738f7c360315f8a03779406cd000ac2f3c767e9
Related CVEs affecting Phpseclib
CVE-2026-1357 9.8 The Migration, Backup, Staging – WPvivid Backup & Migration plugin for WordPr... CVE-2023-27560 7.5 Math/PrimeField.php in phpseclib 3.x before 3.0.19 has an infinite loop with ... CVE-2023-49316 7.5 In Math/BinaryField.php in phpseclib 3 before 3.0.34, excessively large degre... CVE-2024-27354 7.5 An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, an... CVE-2024-27355 7.5 An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, an...
View all Phpseclib CVEs →

ICS/OT Vulnerability Intelligence for Your Environment

BreachSpider tracks 384,000+ CVEs and matches them to your ICS/OT assets by exact version, with AI analysis, NERC CIP mapping, and vendor PSIRT contacts.

Create a free account →