CVE-2026-48172

● Known-exploited CRITICAL

LiteSpeed User-End cPanel Plugin before 2.4.5 allows privilege escalation (possibly to root), as exploited in the wild in May 2026. Detection is best done via a command line of grep -rE "cpanel_jso...

Affects 0 products across 6 vendors.

CVSS 3.19.8
CVSS v410.0
EPSS1.0%
Percentile62th
PatchUnknown
Known-exploited since2026-05-26
CVSS Vector — Plain English Remotely exploitable over the network, low complexity, no authentication required, no user interaction needed, impact contained to the vulnerable component, full confidentiality impact, full integrity impact, full availability impact.
CWE Weakness Definitions
CWE-266: CWE-266
◆ AI Analysis — automated analysis, not human-reviewed

A low severity vulnerability affects Block systems (CVE-2026-48172). A proof-of-concept has been published. Review vendor advisories and apply patches during the next maintenance window.

BSID: BS-2026-GLOBAL-268896-I • Model: rule-based-v1 • Confidence: LOW

Is this CVE in your environment?

BreachSpider monitors your ICS/OT environment for vulnerabilities like this one. No agents or network access required. Free to start.

Check My Environment →
Frequently Asked Questions
What is CVE-2026-48172?
A low severity vulnerability affects Block systems (CVE-2026-48172). A proof-of-concept has been published. Review vendor advisories and apply patches during the next maintenance window.
What is the CVSS score for CVE-2026-48172?
CVE-2026-48172 has CVSS 9.8 (Critical). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H. EPSS: 1.0%.
Is CVE-2026-48172 actively exploited?
Yes. CVE-2026-48172 is in the CISA known-exploited catalog (added 2026-05-26). Active exploitation confirmed. Immediate patching required.
How do I remediate CVE-2026-48172?
Priority: MONITOR. Advisory: https://blog.litespeedtech.com/2026/05/21/security-update-for-litespeed-cpanel-plugin/
What systems are affected by CVE-2026-48172?
CVE-2026-48172 affects Block; Cpanel; Determine; Plugin; Redis; Valid.
Vulnerability Details
CVE IDCVE-2026-48172
BSIDBS-2026-GLOBAL-268896-I BreachSpider Global ID
CVSS VectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published2026-05-21
Last Modified2026-10-07
ICS Relevance0%
Weakness (CWE)
SourceNVD
Official Description

LiteSpeed User-End cPanel Plugin before 2.4.5 allows privilege escalation (possibly to root), as exploited in the wild in May 2026. Detection is best done via a command line of grep -rE "cpanel_jsonapi_func=redisAble" /var/cpanel/logs /usr/local/cpanel/logs/ 2>/dev/null in Bash. If you get no output, you have not been hit with exploitation of the vulnerability. If there is output, we recommend you examine the IP addresses in the list, determine if they are valid IP addresses, and if not, block them. To determine damage done, examine the system logs for use by the detected IP addresses. The issue is related to mishandling of Redis enable/disable features. The recommended minimum version is 2.4.7.

Source: NIST NVD / MITRE CVE Database

Attack Vector Analysis — CITED Relevance

Vulnerability details: LiteSpeed User-End cPanel Plugin before 2.4.5 allows privilege escalation (possibly to root), as exploited in the wild in May 2026. Detection is best done via a command line of grep -rE "cpanel_jsonapi_func=redisAble" /var/cpanel/logs /usr/local/cpanel/logs/ 2>/dev/null in Bash. If you get no output, you have not been hit with exploitation of the vulnerability. If there is output, we recommend you examine the IP addresses in the list, determine if they are valid IP addresses, and if not, block t CVSS vector: Not available.

Exploitation Likelihood: MEDIUM

Affected Products
VendorProductAffected Versions
Block — —
Cpanel — —
Determine — —
Plugin — —
Redis — —
Valid — —
Litespeedtech Litespeed Cpanel Plugin < 2.4.7
Litespeedtech Litespeed Whm Plugin < 5.3.1.0
Remediation
View Vendor Advisory →

Remediation Priority: MONITOR

Threat Intelligence
● Threat Intelligence Validated: October 2026 | Threat Age: 148 Days
CISA known-exploited● Active Exploitation Confirmed (added 2026-05-26)
Public ExploitNot confirmed
PoC CodeNot confirmed
AI Enrichment Record — provenance & audit hash
Modelrule-based-v1
ConfidenceLOW
Enriched At2026-05-24
SHA-512 Audit Hash2c280a8b00c872dd0e7f3db9d49580256091f4083549d0529dd6a6aaf43546db3c2a5fca770c4d36cb64dce81649efb28b752366d4877259752afb31ab4fd79a
Related CVEs affecting Block
CVE-2025-65108 10.0 md-to-pdf is a CLI tool for converting Markdown files to PDF using Node.js an... CVE-2024-8672 9.9 The Widget Options – The #1 WordPress Widget & Block Control Plugin plugin fo... CVE-2026-25345 9.9 Improper Validation of Specified Quantity in Input vulnerability in GalleryCr... CVE-2025-68794 9.8 In the Linux kernel, the following vulnerability has been resolved: iomap: a... CVE-2026-34415 9.8 Xerte Online Toolkits versions 3.15 and earlier contain an incomplete input v...
View all Block CVEs →

This Vulnerability Is Being Actively Exploited

CVE-2026-48172 is on the CISA known-exploited list - confirmed active exploitation in the wild. BreachSpider flags known-exploited CVEs on the ICS assets they affect, with known-exploited status synced daily from CISA.

Create a free account →