CVE-2012-2399

CRITICAL

Cross-site scripting (XSS) vulnerability in swfupload.swf in SWFupload 2.2.0.1 and earlier, as used in WordPress before 3.5.2, TinyMCE Image Manager 1.1 and earlier, and other products allows remot...

Affects 1 product across 1 vendor.

CVSS 2.010.0
EPSS8.6%
Percentile95th
PatchUnknown
CVSS Vector — Plain English Remotely exploitable over the network, low complexity.
◆ AI Analysis — automated analysis, not human-reviewed

This vulnerability was disclosed in 2012. A critical vulnerability affects Wordpress systems (CVE-2012-2399). No public exploit code is currently available. Isolate affected systems if patching is not feasible.

BSID: BS-2012-GLOBAL-315261-C • Model: rule-based-v1 • Confidence: MEDIUM

Is this CVE in your environment?

BreachSpider monitors your ICS/OT environment for vulnerabilities like this one. No agents or network access required. Free to start.

Check My Environment →
Frequently Asked Questions
What is CVE-2012-2399?
This vulnerability was disclosed in 2012. A critical vulnerability affects Wordpress systems (CVE-2012-2399). No public exploit code is currently available. Isolate affected systems if patching is not feasible.
What is the CVSS score for CVE-2012-2399?
CVE-2012-2399 has CVSS 10.0 (Critical). Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C. EPSS: 8.6%.
Is CVE-2012-2399 actively exploited?
No confirmed active exploitation of CVE-2012-2399 as of 2026-09-25.
How do I remediate CVE-2012-2399?
Priority: MEDIUM. Advisory: http://wordpress.org/news/2012/04/wordpress-3-3-2/ PSIRT: [email protected]
What systems are affected by CVE-2012-2399?
CVE-2012-2399 affects Wordpress Wordpress.
Vulnerability Details
CVE IDCVE-2012-2399
BSIDBS-2012-GLOBAL-315261-C BreachSpider Global ID
CVSS VectorAV:N/AC:L/Au:N/C:C/I:C/A:C
Published2012-04-21
Last Modified2026-06-16
ICS Relevance0%
SourceNVD
Official Description

Cross-site scripting (XSS) vulnerability in swfupload.swf in SWFupload 2.2.0.1 and earlier, as used in WordPress before 3.5.2, TinyMCE Image Manager 1.1 and earlier, and other products allows remote attackers to inject arbitrary web script or HTML via the buttonText parameter, a different vulnerability than CVE-2012-3414.

Source: NIST NVD / MITRE CVE Database

Attack Vector Analysis — CITED Relevance

Vulnerability details: Cross-site scripting (XSS) vulnerability in swfupload.swf in SWFupload 2.2.0.1 and earlier, as used in WordPress before 3.5.2, TinyMCE Image Manager 1.1 and earlier, and other products allows remote attackers to inject arbitrary web script or HTML via the buttonText parameter, a different vulnerability than CVE-2012-3414. CVSS vector: AV:N/AC:L/Au:N/C:C/I:C/A:C.

Exploitation Likelihood: LOW

Affected Products
VendorProductAffected Versions
Wordpress Wordpress ≤ 3.3.1
Remediation
View Vendor Advisory →

Remediation Priority: MEDIUM

Vendor PSIRT: [email protected]
Threat Intelligence
● Threat Intelligence Validated: October 2026 | Threat Age: 5290 Days
CISA known-exploitedNot in KEV catalog
Public ExploitNot confirmed
PoC CodeNot confirmed
AI Enrichment Record — provenance & audit hash
Modelrule-based-v1
ConfidenceMEDIUM
Enriched At2026-05-24
SHA-512 Audit Hash7c335a024ddb54bc95c3371c21719bc923587c0b33e02aa17f5089f8eb27fa8fb7ed501a82f44ee752c89910c30a9459fae5d2530807c18e8686329d9e394b39
Related CVEs affecting Wordpress
CVE-2006-4028 10.0 Multiple unspecified vulnerabilities in WordPress before 2.0.4 have unknown i... CVE-2008-3362 10.0 Unrestricted file upload vulnerability in upload.php in the Giulio Ganci Wp D... CVE-2008-6767 10.0 wp-admin/upgrade.php in WordPress, probably 2.6.x, allows remote attackers to... CVE-2012-3575 10.0 Unrestricted file upload vulnerability in uploader.php in the RBX Gallery plu... CVE-2011-5254 10.0 Unspecified vulnerability in the Connections plugin before 0.7.1.6 for WordPr...
View all Wordpress CVEs →

Critical Severity - Know Your Exposure

A CVSS 10.0 vulnerability in your ICS environment cannot wait. BreachSpider maps critical CVEs to your specific assets and tells you what to fix first.

Create a free account →