CVE-2020-36846

CRITICAL

A buffer overflow, as described in CVE-2020-8927, exists in the embedded Brotli library.  Versions of IO::Compress::Brotli prior to 0.007 included a version of the brotli library prior to version 1...

Affects 0 products across 2 vendors.

CVSS 3.19.8
EPSS0.6%
Percentile49th
PatchUnknown
CVSS Vector — Plain English Remotely exploitable over the network, low complexity, no authentication required, no user interaction needed, impact contained to the vulnerable component, full confidentiality impact, full integrity impact, full availability impact.
◆ AI Analysis — automated analysis, not human-reviewed

A buffer overflow vulnerability exists in the embedded Brotli library within versions of IO::Compress::Brotli prior to 0.007, allowing an attacker to trigger a crash by controlling the input length of a decompression request.

BSID: BS-2025-GLOBAL-205603-C • Model: /workspace/models/qwen2.5-coder-32b-instruct-bf16 • Confidence: HIGH

Is this CVE in your environment?

BreachSpider monitors your ICS/OT environment for vulnerabilities like this one. No agents or network access required. Free to start.

Check My Environment →
Frequently Asked Questions
What is CVE-2020-36846?
A buffer overflow vulnerability exists in the embedded Brotli library within versions of IO::Compress::Brotli prior to 0.007, allowing an attacker to trigger a crash by controlling the input length of a decompression request.
What is the CVSS score for CVE-2020-36846?
CVE-2020-36846 has CVSS 9.8 (Critical). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H. EPSS: 0.6%.
Is CVE-2020-36846 actively exploited?
No confirmed active exploitation of CVE-2020-36846 as of 2026-09-25.
How do I remediate CVE-2020-36846?
Priority: IMMEDIATE.
What systems are affected by CVE-2020-36846?
CVE-2020-36846 affects Cannot; Script.
Vulnerability Details
CVE IDCVE-2020-36846
BSIDBS-2025-GLOBAL-205603-C BreachSpider Global ID
CVSS VectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published2025-05-30
Last Modified2026-06-17
ICS Relevance0%
SourceNVD
Official Description

A buffer overflow, as described in CVE-2020-8927, exists in the embedded Brotli library.  Versions of IO::Compress::Brotli prior to 0.007 included a version of the brotli library prior to version 1.0.8, where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your IO::Compress::Brotli module to 0.007 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.

Source: NIST NVD / MITRE CVE Database

Attack Vector Analysis — CITED Relevance

An attacker can exploit this vulnerability by providing a specially crafted input to a script that uses the affected version of IO::Compress::Brotli. The vulnerability is triggered during the 'one-shot' decompression process when handling data chunks larger than 2 GiB, leading to a buffer overflow and potential crash.

Exploitation Likelihood: HIGH

Affected Products
VendorProductAffected Versions
Cannot — —
Script — —
Remediation

No official vendor advisory link on record. See the CVE record →

Threat Intelligence
● Threat Intelligence Validated: October 2026 | Threat Age: 504 Days
CISA known-exploitedNot in KEV catalog
Public ExploitNot confirmed
PoC CodeNot confirmed
AI Enrichment Record — provenance & audit hash
Model/workspace/models/qwen2.5-coder-32b-instruct-bf16
ConfidenceHIGH
Enriched At2026-05-24
SHA-512 Audit Hash157d889be9d034396448e18a55104883281f8b4ec99364f6766853506ed72d8c935c921c21c84b10ad1ad31ceeb4b028e7fa2c6046cec67274c285f7bc52f80f
Related CVEs affecting Cannot
CVE-2025-30519 9.8 Dover Fueling Solutions ProGauge MagLink LX4 Devices have default root creden... CVE-2025-40343 9.8 In the Linux kernel, the following vulnerability has been resolved: nvmet-fc... CVE-2025-40350 9.8 In the Linux kernel, the following vulnerability has been resolved: net/mlx5... CVE-2025-68359 9.8 In the Linux kernel, the following vulnerability has been resolved: btrfs: f... CVE-2025-43982 9.8 Shenzhen Tuoshi NR500-EA RG500UEAABxCOMSLICv3.4.2731.16.43 devices enable the...
View all Cannot CVEs →

Critical Severity - Know Your Exposure

A CVSS 9.8 vulnerability in your ICS environment cannot wait. BreachSpider maps critical CVEs to your specific assets and tells you what to fix first.

Create a free account →