CVE-2024-30170
PrivX before 34.0 allows data exfiltration and denial of service via the REST API. This is fixed in minor versions 33.1, 32.3, 31.3, and later, and in major version 34.0 and later,
Affects 1 product across 1 vendor.
Software does not properly limit resource usage, allowing an attacker to exhaust CPU, memory, disk, or bandwidth.
Mapping is CWE-to-CAPEC per MITRE CAPEC 3.9.
PrivX versions prior to 34.0 are vulnerable to data exfiltration and denial of service attacks through the REST API.
BSID: BS-2024-GLOBAL-047739-C • Model: /workspace/models/qwen2.5-coder-32b-instruct-bf16 • Confidence: HIGH
Is this CVE in your environment?
BreachSpider monitors your ICS/OT environment for vulnerabilities like this one. No agents or network access required. Free to start.
Check My Environment →What is CVE-2024-30170?
What is the CVSS score for CVE-2024-30170?
Is CVE-2024-30170 actively exploited?
How do I remediate CVE-2024-30170?
What systems are affected by CVE-2024-30170?
| CVE ID | CVE-2024-30170 |
|---|---|
| BSID | BS-2024-GLOBAL-047739-C BreachSpider Global ID |
| CVSS Vector | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H |
| Published | 2024-08-06 |
| Last Modified | 2024-08-12 |
| ICS Relevance | 15% |
| Weakness (CWE) | |
| Source | NVD |
PrivX before 34.0 allows data exfiltration and denial of service via the REST API. This is fixed in minor versions 33.1, 32.3, 31.3, and later, and in major version 34.0 and later,
Source: NIST NVD / MITRE CVE Database
An attacker can exploit the vulnerability by sending malicious requests to the REST API, leading to unauthorized data access and potential service disruption.
Exploitation Likelihood: HIGH
| Vendor | Product | Affected Versions |
|---|---|---|
| Ssh | Privx | 33.0 ≥ 22.0, < 31.3 ≥ 32.0, < 32.3 |
| CISA known-exploited | Not in KEV catalog |
|---|---|
| Public Exploit | Not confirmed |
| PoC Code | Not confirmed |
AI Enrichment Record — provenance & audit hash
| Model | /workspace/models/qwen2.5-coder-32b-instruct-bf16 |
|---|---|
| Confidence | HIGH |
| Enriched At | 2026-05-24 |
| SHA-512 Audit Hash | 0fe7f3adc4f782bc092837cd762dbec017f97dcd571cf39d634c7e23e4db048e76a51f21823ada44b2a087a0c6a72392962d0b3277ad2d2ae78df6907d9b42ff |
Critical Severity - Know Your Exposure
A CVSS 9.1 vulnerability in your ICS environment cannot wait. BreachSpider maps critical CVEs to your specific assets and tells you what to fix first.
Create a free account →