CVE-2025-40914

CRITICAL

Perl CryptX before version 0.087 contains a dependency that may be susceptible to an integer overflow. CryptX embeds a version of the libtommath library that is susceptible to an integer overflow ...

Affects 0 products across 1 vendor.

CVSS 3.19.8
EPSS0.5%
Percentile44th
PatchUnknown
CVSS Vector — Plain English Remotely exploitable over the network, low complexity, no authentication required, no user interaction needed, impact contained to the vulnerable component, full confidentiality impact, full integrity impact, full availability impact.
◆ AI Analysis — automated analysis, not human-reviewed

Perl CryptX before version 0.087 contains a dependency on libtommath that is vulnerable to an integer overflow, which could lead to arbitrary code execution.

BSID: BS-2025-GLOBAL-259415-C • Model: /workspace/models/qwen2.5-coder-32b-instruct-bf16 • Confidence: HIGH

Is this CVE in your environment?

BreachSpider monitors your ICS/OT environment for vulnerabilities like this one. No agents or network access required. Free to start.

Check My Environment →
Frequently Asked Questions
What is CVE-2025-40914?
Perl CryptX before version 0.087 contains a dependency on libtommath that is vulnerable to an integer overflow, which could lead to arbitrary code execution.
What is the CVSS score for CVE-2025-40914?
CVE-2025-40914 has CVSS 9.8 (Critical). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H. EPSS: 0.5%.
Is CVE-2025-40914 actively exploited?
No confirmed active exploitation of CVE-2025-40914 as of 2026-05-30.
How do I remediate CVE-2025-40914?
Priority: IMMEDIATE.
What systems are affected by CVE-2025-40914?
CVE-2025-40914 affects Associated.
Vulnerability Details
CVE IDCVE-2025-40914
BSIDBS-2025-GLOBAL-259415-C BreachSpider Global ID
CVSS VectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published2025-06-11
Last Modified2026-04-15
ICS Relevance0%
SourceNVD
Official Description

Perl CryptX before version 0.087 contains a dependency that may be susceptible to an integer overflow. CryptX embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328.

Source: NIST NVD / MITRE CVE Database

Attack Vector Analysis — CITED Relevance

An attacker could exploit the integer overflow vulnerability in the embedded libtommath library to execute arbitrary code on systems running Perl CryptX versions prior to 0.087. This could be achieved by crafting specific inputs that trigger the overflow condition.

Exploitation Likelihood: HIGH

Affected Products
VendorProductAffected Versions
Associated — —
Remediation

No official vendor advisory link on record. See the CVE record →

Threat Intelligence
● Threat Intelligence Validated: October 2026 | Threat Age: 491 Days
CISA known-exploitedNot in KEV catalog
Public ExploitNot confirmed
PoC CodeNot confirmed
AI Enrichment Record — provenance & audit hash
Model/workspace/models/qwen2.5-coder-32b-instruct-bf16
ConfidenceHIGH
Enriched At2026-05-24
SHA-512 Audit Hashd3def57831e7c6d6bd9c22ac4b3ace63875ced761474193bdfd0511519990ce4f022e21244dd7378f6666d49e582f9e462a1fe03f5f573c2a9e0635fe7b2de0a
Related CVEs affecting Associated
CVE-2024-2086 10.0 The Integrate Google Drive – Browse, Upload, Download, Embed, Play, Share, Ga... CVE-2026-5229 9.8 The Form Notify plugin for WordPress is vulnerable to Authentication Bypass i... CVE-2024-45337 9.1 Applications and libraries which misuse connection.serverAuthenticate (via ca... CVE-2025-40362 8.8 In the Linux kernel, the following vulnerability has been resolved: ceph: fi... CVE-2025-68304 8.8 In the Linux kernel, the following vulnerability has been resolved: Bluetoot...
View all Associated CVEs →

Critical Severity - Know Your Exposure

A CVSS 9.8 vulnerability in your ICS environment cannot wait. BreachSpider maps critical CVEs to your specific assets and tells you what to fix first.

Create a free account →