CVE-2026-34234
CtrlPanel is open-source billing software for hosting providers. In versions 1.1.1 and prior, the web-based installer (public/installer/index.php) is vulnerable to unauthenticated Remote Code Execu...
Affects 0 products across 1 vendor.
Attacker injects OS commands through application inputs passed to system() or equivalent calls, leading to arbitrary command execution.
Software does not restrict or incorrectly restricts access to a resource.
Show all 22
Mapping is CWE-to-CAPEC per MITRE CAPEC 3.9.
CtrlPanel versions 1.1.1 and prior are vulnerable to unauthenticated Remote Code Execution (RCE) due to improper handling of the install.lock check in the web-based installer.
BSID: BS-2026-GLOBAL-151150-C • Model: /workspace/models/qwen2.5-coder-32b-instruct-bf16 • Confidence: HIGH
Is this CVE in your environment?
BreachSpider monitors your ICS/OT environment for vulnerabilities like this one. No agents or network access required. Free to start.
Check My Environment →What is CVE-2026-34234?
What is the CVSS score for CVE-2026-34234?
Is CVE-2026-34234 actively exploited?
How do I remediate CVE-2026-34234?
What systems are affected by CVE-2026-34234?
| CVE ID | CVE-2026-34234 |
|---|---|
| BSID | BS-2026-GLOBAL-151150-C BreachSpider Global ID |
| CVSS Vector | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H |
| Published | 2026-05-19 |
| Last Modified | 2026-07-24 |
| ICS Relevance | 15% |
| Weakness (CWE) | |
| Source | NVD |
CtrlPanel is open-source billing software for hosting providers. In versions 1.1.1 and prior, the web-based installer (public/installer/index.php) is vulnerable to unauthenticated Remote Code Execution (RCE) because it performs the install.lock check only after including and executing form handler files, leaving installer endpoints reachable on already-installed instances. The handlers also pass unsanitized user input directly into shell commands, allowing an attacker to submit crafted requests that execute arbitrary commands on the server. The vulnerability stems from two combined weaknesses: (1) premature form handler execution before the lock file gate, and (2) unsafe use of user input in shell command construction. This issue is reported to be actively exploited in the wild. The issue has been fixed in version 1.2.0.
Source: NIST NVD / MITRE CVE Database
The vulnerability exists in the public/installer/index.php file, where form handler files are included and executed before the install.lock check is performed. This allows attackers to reach installer endpoints on already-installed instances and potentially execute arbitrary code.
Exploitation Likelihood: CRITICAL
| Vendor | Product | Affected Versions |
|---|---|---|
| Form | — | — |
No official vendor advisory link on record. See the CVE record →
| CISA known-exploited | Not in KEV catalog |
|---|---|
| Public Exploit | Not confirmed |
| PoC Code | Not confirmed |
AI Enrichment Record — provenance & audit hash
| Model | /workspace/models/qwen2.5-coder-32b-instruct-bf16 |
|---|---|
| Confidence | HIGH |
| Enriched At | 2026-05-24 |
| SHA-512 Audit Hash | bb10196081a5b838f6eebb3224ab6afcfa358e9fc78f95bebcda02c9cd5af54af9d18d2e50f69ddb5d46ca046f315e5b0ee4f12a8eef2ead5d0f090bd06572ae |
Critical Severity - Know Your Exposure
A CVSS 10.0 vulnerability in your ICS environment cannot wait. BreachSpider maps critical CVEs to your specific assets and tells you what to fix first.
Create a free account →