CVE-2025-30796

HIGH

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Extended The Ultimate WordPress Toolkit – WP Extended wpextended allows Reflected XSS.This i...

Affects 0 products across 2 vendors.

CVSS 3.17.1
EPSS0.3%
Percentile22th
PatchUnknown
CVSS Vector — Plain English Remotely exploitable over the network, low complexity, no authentication required, requires user interaction, can impact systems beyond the vulnerable component.
CWE Weakness Definitions
CWE-79: Cross-Site Scripting (XSS)

Attacker injects malicious scripts into web pages viewed by other users, executing in the victim's browser context.

Related Attack Patterns (CAPEC)
CAPEC-85 AJAX Footprinting
via CWE-79
CAPEC-209 XSS Using MIME Type Mismatch
via CWE-79
CAPEC-588 DOM-Based XSS
via CWE-79
CAPEC-591 Reflected XSS
via CWE-79
CAPEC-592 Stored XSS
via CWE-79
Show all 6
via CWE-79

Mapping is CWE-to-CAPEC per MITRE CAPEC 3.9.

◆ AI Analysis — automated analysis, not human-reviewed

A Cross-site Scripting (XSS) vulnerability exists in WP Extended The Ultimate WordPress Toolkit – WP Extended wpextended, affecting versions up to 3.0.14. This issue arises from improper neutralization of input during web page generation, allowing attackers to execute arbitrary scripts in the context of other users' browsers.

BSID: BS-2025-GLOBAL-252122-H • Model: /workspace/models/qwen2.5-coder-32b-instruct-bf16 • Confidence: HIGH

Is this CVE in your environment?

BreachSpider monitors your ICS/OT environment for vulnerabilities like this one. No agents or network access required. Free to start.

Check My Environment →
Frequently Asked Questions
What is CVE-2025-30796?
A Cross-site Scripting (XSS) vulnerability exists in WP Extended The Ultimate WordPress Toolkit – WP Extended wpextended, affecting versions up to 3.0.14. This issue arises from improper neutralization of input during web page generation, allowing attackers to execute arbitrary scripts in the context of other users' browsers.
What is the CVSS score for CVE-2025-30796?
CVE-2025-30796 has CVSS 7.1 (High). Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L. EPSS: 0.3%.
Is CVE-2025-30796 actively exploited?
No confirmed active exploitation of CVE-2025-30796 as of 2026-05-30.
How do I remediate CVE-2025-30796?
Priority: HIGH.
What systems are affected by CVE-2025-30796?
CVE-2025-30796 affects Wordpress; Wpextended.
Vulnerability Details
CVE IDCVE-2025-30796
BSIDBS-2025-GLOBAL-252122-H BreachSpider Global ID
CVSS VectorCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
Published2025-04-01
Last Modified2026-04-23
ICS Relevance0%
Weakness (CWE)
SourceNVD
Official Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Extended The Ultimate WordPress Toolkit – WP Extended wpextended allows Reflected XSS.This issue affects The Ultimate WordPress Toolkit – WP Extended: from n/a through <= 3.0.14.

Source: NIST NVD / MITRE CVE Database

Attack Vector Analysis — CITED Relevance

An attacker can exploit this vulnerability by injecting malicious scripts into input fields that are not properly sanitized. When other users view the affected web pages, the scripts are executed in their browsers, potentially leading to unauthorized actions, data theft, or session hijacking.

Exploitation Likelihood: MEDIUM

Affected Products
VendorProductAffected Versions
Wordpress — —
Wpextended — —
Remediation

No official vendor advisory link on record. See the CVE record →

Threat Intelligence
● Threat Intelligence Validated: October 2026 | Threat Age: 563 Days
CISA known-exploitedNot in KEV catalog
Public ExploitNot confirmed
PoC CodeNot confirmed
AI Enrichment Record — provenance & audit hash
Model/workspace/models/qwen2.5-coder-32b-instruct-bf16
ConfidenceHIGH
Enriched At2026-05-24
SHA-512 Audit Hashd7562af4871aebd5e3476af0262675d20ef0bbc8ed47cd712978afca7c672e9f6a2c26638fe254053deb66ef22dd05359ee778094b81e5abe6c9c7f01623c3f6
Related CVEs affecting Wordpress
CVE-2012-2399 10.0 Cross-site scripting (XSS) vulnerability in swfupload.swf in SWFupload 2.2.0.... CVE-2012-3575 10.0 Unrestricted file upload vulnerability in uploader.php in the RBX Gallery plu... CVE-2006-4028 10.0 Multiple unspecified vulnerabilities in WordPress before 2.0.4 have unknown i... CVE-2008-3362 10.0 Unrestricted file upload vulnerability in upload.php in the Giulio Ganci Wp D... CVE-2008-6767 10.0 wp-admin/upgrade.php in WordPress, probably 2.6.x, allows remote attackers to...
View all Wordpress CVEs →

ICS/OT Vulnerability Intelligence for Your Environment

BreachSpider tracks 384,000+ CVEs and matches them to your ICS/OT assets by exact version, with AI analysis, NERC CIP mapping, and vendor PSIRT contacts.

Create a free account →