CVE-2025-14691
A vulnerability was detected in Mayan EDMS up to 4.10.1. The affected element is an unknown function of the file /authentication/. The manipulation results in cross site scripting. The attack may b...
Affects 1 product across 1 vendor.
Attacker injects malicious scripts into web pages viewed by other users, executing in the victim's browser context.
Attacker injects arbitrary code that is executed by the application process.
Show all 9
Mapping is CWE-to-CAPEC per MITRE CAPEC 3.9.
A cross-site scripting (XSS) vulnerability was identified in Mayan EDMS up to version 4.10.1, affecting an unknown function in the /authentication/ file. This vulnerability can be exploited remotely, and the exploit is publicly available.
BSID: BS-2025-GLOBAL-233921-M • Model: /workspace/models/qwen2.5-coder-32b-instruct-bf16 • Confidence: MEDIUM
Is this CVE in your environment?
BreachSpider monitors your ICS/OT environment for vulnerabilities like this one. No agents or network access required. Free to start.
Check My Environment →What is CVE-2025-14691?
What is the CVSS score for CVE-2025-14691?
Is CVE-2025-14691 actively exploited?
How do I remediate CVE-2025-14691?
What systems are affected by CVE-2025-14691?
| CVE ID | CVE-2025-14691 |
|---|---|
| BSID | BS-2025-GLOBAL-233921-M BreachSpider Global ID |
| CVSS Vector | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N |
| Published | 2025-12-14 |
| Last Modified | 2026-10-07 |
| ICS Relevance | 15% |
| Weakness (CWE) | |
| Source | NVD |
A vulnerability was detected in Mayan EDMS up to 4.10.1. The affected element is an unknown function of the file /authentication/. The manipulation results in cross site scripting. The attack may be performed from remote. The exploit is now public and may be used. Upgrading to version 4.10.2 is sufficient to fix this issue. You should upgrade the affected component. The vendor confirms that this is "[f]ixed in version 4.10.2". Furthermore, that "[b]ackports for older versions in process and will be out as soon as their respective CI pipelines complete."
Source: NIST NVD / MITRE CVE Database
The attack vector involves an unknown function in the /authentication/ file of Mayan EDMS, which can be exploited to perform cross-site scripting. The vulnerability can be triggered remotely, and the exploit is publicly available.
Exploitation Likelihood: MEDIUM
| Vendor | Product | Affected Versions |
|---|---|---|
| Mayan-Edms | Mayan Edms | < 4.10.2 |
No official vendor advisory link on record. See the CVE record →
| CISA known-exploited | Not in KEV catalog |
|---|---|
| Public Exploit | Not confirmed |
| PoC Code | Not confirmed |
AI Enrichment Record — provenance & audit hash
| Model | /workspace/models/qwen2.5-coder-32b-instruct-bf16 |
|---|---|
| Confidence | MEDIUM |
| Enriched At | 2026-05-24 |
| SHA-512 Audit Hash | eb8bdfb7735cf204508ac478e2f59e85dc56198c461e7799b8344af66255c666d2173c4f96f528a07664dad6254adb0c9c267085cb150d0c4a89328b0d5d3970 |
ICS/OT Vulnerability Intelligence for Your Environment
BreachSpider tracks 384,000+ CVEs and matches them to your ICS/OT assets by exact version, with AI analysis, NERC CIP mapping, and vendor PSIRT contacts.
Create a free account →